Deze plugin is verouderd of niet getest met de huidige versie van WordPress, wat nu?

plugin up-to-date
Leestijd:
3 minuten
Leesniveau:
Onbekend
Waardering:

This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Als je deze melding ziet bij het opzoeken van een plugin op WordPress.org vraag je je vast af of de plugin nog veilig is, en of je de plugin wel kunt installeren of kunt blijven gebruiken.

Als eerste, als er een lek bekend is kun je die zien op deze website: wpvulndb.com
Gebruik de zoekbalk om te kijken of de plugin bekent is en of er een lek is.
Wat betekend “lek”? Lek houdt in dat hackers een manier gevonden hebben om je website aan te passen via een onveilig stukje code van die plugin.

Wat betekent “hasn’t been tested with the latest 3 major releases of WordPress“?
Dat betekent dat er nieuwe releases (updates) van WordPress uitgebracht zijn en dat de pluginbouwer niet heeft bevestigd dat hij de plugin getest heeft op de nieuwste versies van WordPress.
Op zich is dit niet gek, want WordPress brengt veel updates uit. Die zijn voor veel drukke pluginbouwers niet bij te houden.
Op zich hoeft het geen probleem te zijn als de pluginbouwer de plugin nog niet getest heeft, maar de gele balk verschijnt wel direct bij een nieuwe WordPress release!
Gezien dat WordPress vaak “backwards compatible” is en dus oudere code behoudt zodat plugins en thema’s er nog mee kunnen werken, zal de plugin meestal op de nieuwere versies van WordPress blijven functioneren.

Wat betekent “It may no longer be maintained“? Letterlijk vertaald staat er dat de plugin wordt misschien niet meer onderhouden wordt door de pluginbouwer.
Je kunt zien of de plugin echt niet meer bijgewerkt wordt, bij de plugin staat namelijk altijd wanneer de plugin voor het laatst ge-update is.

laatst geupdate

5-10 maanden is niet zo’n probleem. Als een plugin 1-3 jaar niet meer geupdate is kun je er vanuit gaan dat de plugin echt vergeten wordt door de pluginbouwer en dat er geen updates meer komen.

Als er totaal geen updates meer komen is het aan te raden een andere plugin te zoeken.

Wat betekent  “may have compatibility issues”?
Er kunnen problemen ontstaan wanneer plugins niet meer up-to-date gehouden worden.
De plugin kan bijvoorbeeld helemaal niet meer werken, of de styling van je website door elkaar gooien of andere functionaliteiten van je website kunnen uitvallen.
Soms werkt de plugin zelf nog goed maar veroorzaakt hij een error waardoor andere plugins niet meer functioneren. Daardoor zou je zelfs de verkeerde plugin kunnen verwijderen omdat je denkt dat die problemen veroorzaakt.

Conclusie: Zie je een gele waarschuwingsbalk bij de plugin met de melding dat de plugin verouderd is, of niet getest is met de huidige versie van WordPress.. dan weet je dat je moet kijken naar de datum dat de plugin voor het laatst ge-update is.
Aan de hand daarvan kun je bepalen of je de plugin nog wel wilt gebruiken.

De gele balk an sich is geen enkele reden om de plugin te verwijderen of niet te installeren!

 

 

Hoe nuttig was dit artikel?

Vergeet niet te delen

0
Reacties

Deel je mening of stel een vraag:

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *